<menu id="m0oww"></menu>
<input id="m0oww"></input>
  • <menu id="m0oww"></menu>
  • <input id="m0oww"></input>
    <menu id="m0oww"></menu>
  • <input id="m0oww"><tt id="m0oww"></tt></input>
    <input id="m0oww"></input>
    < 返回新聞公共列表

    關于“Linux底層函數庫glibc出現重大安全漏洞”公告

    發布時間:2019-11-19 14:43:42

    尊敬的用戶:

    您好!

    外界安全研究人員發現:Linux底層函數庫glibc再現重大安全漏洞。

    漏洞成因在于glibc中處理DNS查詢的代碼存在棧溢出漏洞,遠端攻擊者可以通過DNS服務回應特定構造的DNS響應數據包,造成風險。

     [受影響系統]

    CentOS6 所有版本

    CentOS7 所有版本

    SUSE Linux Enterprise Server 11 SP3

    SUSE Linux Enterprise Server 12

    Ubuntu Server 14.04.1 LTS 32位

    Ubuntu Server 14.04.1 LTS 64位

    Ubuntu Server 12.04 LTS 64位

    Debian 

     [漏洞編號]

    CVE-2015-7547

     [漏洞修復方法]

    根據系統發行版,按照如下更新glibc之后,請務必確定發行版對應glibc的版本,建議在更新后重啟系統。

     CentOS系統

    官方說明鏈接:https://www.linuxos.pro/cve-2015-7547-linux-glibc-bug-vulnerability/

    centos 5.10:不受影響

    centos 5.8:不受影響

    centos 6.X:需要升級到版本: >= glibc-2.12-1.166.el6_7.7

    centos 7.X:需要升級到版本:>= glibc-2.17-106.el7_2.4

    步驟:

    1. 同步源: yum makecache

    2. 升級 glib: yum update glibc

    3. 檢查版本:rpm -q glibc

     Debian系統

    官方說明鏈接:https://security-tracker.debian.org/tracker/CVE-2015-7547

    debian 6:需要升級 libc6 到  >= 2.11.3-4+deb6u11

    debian 7:需要升級 libc6 到 >= 2.13-38+deb7u10

    步驟:

    1. 檢查 libc6 版本: dpkg -l libc6

    2. 對于 debian7,注意需要添加安全補丁源

    2. 同步源:apt-get update

    3. 升級 libc6:apt-get install libc6

    4. 再次檢查 libc6 版本:dpkg -l libc6

     ubuntu系統

    官方說明鏈接:http://www.ubuntu.com/usn/usn-2900-1/

    ubuntu 12:需要升級 libc6 到 >= 2.15-0ubuntu10.13

    ubuntu 14:需要升級 libc6 到 >= 2.19-0ubuntu6.7

    1. 檢查 libc6 版本:dpkg -l libc6

    2. 同步源:apt-get update

    3. 升級 libc6 包:apt-get install libc6

    4. 再次驗證 libc6 版本:dpkg -l libc6